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InRoads – Converting CAiCE Data to InRoads 

Overview 
There are two main types of data that is converted from a standard WSDOT CAiCE project into a 
standard WSDOT InRoads project: design geometry and survey data.  

This process workflow includes writing database elements to translator files, and then deleting them to 
isolate the remaining element types. Below is a short overview of each data type and the conversion 
process for each. 

Design Geometry  
Design geometry includes survey generated elements indicating right-of-way geometry and control, 
design proposed horizontal alignments, offset geometry, and design profiles as well as supplemental 
geometry objects (curves, spirals, lines, etc.) and proposed single-point elements (catch basins, 
luminaires, etc.). 

It is important to account for all data elements, and each element should be considered for including in 
the process. The intent is to create a base clean, workable, and efficient project dataset in InRoads.  

After backing up the project, superelevation reports for each alignment will be backed up (see the Known 
Issues section of this document) and LandXML files will be generated for subsets containing specific 
types of data. They will then be imported into an InRoads Geometry Project. Lastly, the InRoads data sets 
will be saved in their respective file types for use in InRoads. 

After translating design geometry, the data written to LandXML will be deleted from the project. 

Survey Data  
Survey data consists of elements representing 3D terrain information and 2D feature elements typically 
collected by field survey crews and Photogrammetry. These features will be converted into an InRoads 
surface or Digital Terrain Model (DTM) file.  

Survey and Photogrammetry are the only types of CAiCE data that should be converted using this 
method. For all other data, see the Converting Geometry section of this document. 

This procedure relies heavily on the integrity of the survey dataset in CAiCE. It starts by isolating the 
CAiCE survey dataset (survey points and survey chains), and then brings all known codes up to current 
standards. Once all of the known codes are dealt with, the unknown or non-standard codes must be 
evaluated and addressed.  

After all of the codes are within current standards or otherwise addressed, check to make sure that all 
survey chain points are accounted for. Next, an SRV file is created and converted to a ‘WAS’ ASCII file 
for import into InRoads Survey.  

This process uses InRoads Survey to convert current CAiCE standard feature codes to InRoads 
expanded level feature styles.  
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Known issues with this procedure: 

LandXML Writer does not successfully export Parcel data 
• The LandXML Writer in CAiCE writes alignment chains as Alignments and Roadways while 

non-alignment chains, such as EPP and LEP, are considered parcels.  

• Alignments are successfully written to the XML file and may include vertical profiles. InRoads will 
import alignments and associated profiles as long as the profiles do not contain vertical overlaps.  

• Parcels that include curve and spiral data will be incomplete.  

A WSDOT custom utility called XML Export will write all selected geometry chains as alignments for 
converting to InRoads. 

Superelevation tables will not transfer from CAiCE to InRoads 
• Superelevation tables are not compatible between the two applications. The CAiCE to InRoads 

procedures below describe the process of backing up CAiCE superelevation tables into CSV 
format ASCII files. These files make excellent documentation and backup for CAiCE 
superelevation information. They are also compatible with Microsoft Excel (with a little help) and 
can be manipulated and refined in this application.  

• For regenerating superelevation tables for InRoads, either use the internal tools within InRoads or 
use the Superelevation Calculator, which is a WSDOT application-neutral superelevation table 
generator utility that is located in the C:\Users\Public\cae\Standards\WSDOT\Utilities 
folder. 

Non-Standard Codes Will Not be Recognized 
It is imperative that all non-standard codes have been addressed and brought to standards per the CAiCE 
WA_0003.ftb feature table. All unrecognized features will be consolidated into one feature called Default 
in InRoads. 

Point AND Survey Chain capabilities versus Point OR Survey Chain 
In CAiCE, a feature can depict a single instance point or a chain of points independently based on Point 
or Line attributes (For example, a single point spot check on the EL does not need to connect to the next 
EL survey chain point). InRoads feature styles do not have this point vs. line separation. Each feature 
style is either a point or a line. Therefore if a dataset has single point instances of a feature code that is 
typically used as a chain feature, InRoads will graphically draw a line between these points. 

Invalid alpha codes or numeric codes in the WSDOT resources 
Currently, there are a few standard CAiCE feature codes that are alpha-numeric (16SEC, C4F, CB7FL, 
etc.). These codes are included in the WSDOT CAiCE feature table WA_0003.ftb. InRoads accept alpha 
codes and numeric codes, but not alpha-numeric codes. Our process to convert survey data to Inroads 
will account for any STANDARD alpha-numeric codes, however, any design generated or non-standard 
alpha-numeric codes must be revised to a standard alpha code in order to be converted.   
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Clean up the CAiCE project 

In CAiCE: 
1. Archive the project 

NOTE: The WSDOT Project Cleanup utility is useful for identifying appropriate CAiCE data. 

2. Review ALL geometry (geometry chains, profiles points, and survey chains) for current standard 
feature codes and delete all non-relevant or temporary geometry chains.  

3. Create superelevation CSV files for each alignment. This creates a backup file for use in CAiCE 
and MS Excel. 

• Select Geometry > Geometry Chains > Edit Superelevation for Alignment  

• Enter the alignment name and click on Load  

• Right-click in the spreadsheet Smart Grid at the bottom of the dialog  

• Select Table > Export to CSV  

4. Create a KCM file of all remaining curves, spirals, and spiral-curve-spirals for backup purposes. 

5. It is optional at this time to delete all curves, spirals, and spiral-curve-spirals from the project. 

6. Review all remaining points for control and design features such as BM, CP, GPS, IS, MON, 
TCP, EPP, MHP, or UPP. 

7. All control or cadastral points should be written to an XML file  

8. Any proposed feature present at this step that represents a linear element such as EPP or ELP 
should be evaluated. Typically, these points should have been deleted along with the Geometry 
Chains that contain them. If they are present and not necessary, delete them at this point.  

9. Delete all temporary points. 

Converting CAiCE Design Geometry Using LandXML 
Export the geometry data using the LandXML process. There are two methods for exporting the data: 

Method 1 
Use the WSDOT XML Export utility in CAiCE to write the geometry chains to an XML file: 

1. Select the Window  > Explorer Center/Snap Bar command. 

2. Select the Toolbox Explorer tab.  

3. Double-click to open the WSDOTMacroToolbox.  

4. Click the + to expand the Utilities category, and click XML Export to view the macro’s 
description.  

5. Double-click on XML Export a second time to run the application.  

6. In the XML Export dialog, enter the path and name of the new XML file.  

7. Click the Geometry Chains button to select which chains will be exported, and click the 
Points button to select which points will be exported.  
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8. Click Export to generate the XML file.  

Method 2 
Use the CAiCE LandXML Writer to write all geometry chains to an XML file: 

1. Revise all geometry chains by toggling on the Alignment Chain check box in the Geometry > 
Geometry Chains > Store/Edit command. 

NOTE: This can also be done by writing out a KCM, modifying the KCM, and reading the KCM 
back in to the project.  

2. Select the Window > Explorer Center/Snap Bar command. 

3. Select the Toolbox Explorer tab.  

4. Double-click to open the LandXML Toolbox.  

5. Click the "+" to expand Visual LandXML, and click on Visual LandXML Writer to view the 
description.  

6. Double-click on Visual LandXML Writer a second time to run the application.  

7. In the LandXML Writer, deselect Survey Chains, DTM's and Parcels.  

8. Toggle on the Points and Alignments/Roadways boxes and click the Selection 
Criteria button. 

• Points:  select all control, cadastral, and proposed point features  

• Geometry Chains:  Click on the All button to select all geometry chains  

• Indicate associated Design Vertical Profiles  

NOTE:  if the vertical profile includes a vertical overlap (consequential VPI or event stations), it will 
not be imported in InRoads correctly.  

9. Give the XML file a name similar to Projname_All Geometry Chains and Profiles.xml.  

10. Toggle on the Format on separate lines option.  

11. Click Export.  

Converting CAiCE Vertical Profiles 
Export vertical profiles from CAiCE by loading the profile into the Geometry > Profile > Store/Edit 
command.  In the table grid portion, right-click and select Table > Export to CSV  

Importing Vertical Alignments Into InRoads   

In InRoads: 
1. Set the active horizontal alignment. 

2. Select the File > Text Import Wizard command. 

3. First set the Data Type to Vertical Alignment, and then set the Wizard Name  to Classic 
File.  
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4. For the File Name, use the picker to browse to and select the CSV file that was exported from 
CAiCE.  

5. Click OK. 

6. Input the Name, Description and Style. 

7. Click OK. 

8. Verify that the <ProjectName>_WSDOT_standards.xin file listed available 
<ProjectName>\EngDataDesign\_Standards\ folder. 

9. Create a new geometry project by selecting File > New and click on the Geometry tab. 

Verify the Type as Geometry Project. 

10. Enter a project a name such as Projname_Design and a description such as Design Data 
from CAiCE. 

11. Click Apply and then close the dialog. 

Import the Design geometry: 
1. Select the File > Translators > LandXML Translator command. 

2. On the Import tab, click in the File Name:  field and select Browse....  

3. Navigate to the geometry chain XML file that was stored previously.  

4. Highlight the file, click on Open to select it, and then Cancel to complete the selection.  

NOTE:  The filename is displayed in the LandXML command.  

5. Click on Apply and keep the dialog open.  

6. Repeat these steps for the XML that contains the design points, if applicable. 

7. Close the dialog and review the results. 

• In the InRoads Explorer navigate to the Geometry tab in the left pane.  

• Click on the + sign next to the geometry project that was created earlier. 

• NOTE:  The Cogo Buffer can be expanded to show all the proposed points, and all of the 
CAiCE geometry chains are included.  

Converting CAiCE survey to InRoads surface 

In CAiCE: 
1. Archive the project 

NOTE: The WSDOT Project Cleanup utility is useful for identifying appropriate CAiCE data 

2. Isolate the survey data by converting design data to InRoads using the process that was 
described previously in this document  
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Bring all feature codes to current standards: 

3. In the Toolbox Explorer, open the WSDOTMacroToolbox.  

4. Expand the Utilities category.  

5. Run the Change Features tool.  

6. Use the Update Survey.txt conversion file in the C:\CAE_rsc\CAiCE_V10\Table folder.  

7. Click Update. 

Check for non-standard and non-coded survey data: 

8. Verify that the current WSDOT feature table WA_0003.ftb is attached.  

9. Set the default color to Color 8 (pink).  

10. View all points and survey chains and look for any pink colored elements.  

Address all pink colored elements – these have non-standard codes: 

11. Review the list of point features by selecting the View > Points command. 

12. Click on the ? next to the Feature field.  

13. Look for proposed features such as EPSP, and LEP. These indicate proposed elements that 
should be removed or are miscoded features  

Finding elements with no codes requires writing out a KCM of the points. The KCM file can be 
reviewed to show all points with a feature of "".  

NOTE: Only the standard elements will be recognized during the conversion process, so it is 
important that all elements are accounted for.  

CLEAN UP ALL CODES!  

Check for data integrity: 

14. Clear the CAiCE view and select the Window > Text Display command. 

15. Click on the Text Window Errors tab and clear all the contents by highlighting all text and 
pressing the <Delete> key.  

16. View all survey chains.  

17. Review the Text Window Errors tab for any issues while displaying survey  
chains. 

This will show missing points.  

18. Address all errors and check for alpha-numeric codes. 

Alpha-numeric codes are not valid in InRoads and must be addressed prior to translation.  

Create and SRV file: 

19. Select the File > Save > Points and Survey Chains as SRV file command.  

20. Select the All button.  
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21. Click No in the Point Interpolation dialog to prevent CAiCE from creating extra points.  

NOTE: use the SRV file command in the CAiCE File menu only!  Do not use the SRV file 
command in the DTM menu, because this creates an SRV that with a format that is incompatible 
with the WSDOT CAE SRVtoWAS.exe conversion utility. 

Create a WAS file: 

1. Navigate to the C:\CAE_rsc\InRoads Utilities folder and run the SRVtoWAS.exe file. 

2. Enter the SRV file created above as the Input SRV File. 

3. Enter the same name but revise the file extension to .was as the Output WAS File.   

In InRoads: 
1. Access the InRoads Survey module by selecting the Tools > Product Add-ins command. 

2. Toggle ON the InRoads Survey option and click OK to close the dialog box. 

Reference the wsdot_standards.xin file in the C:\CAE_rsc\InRoads\Standards folder. 

3. Create an InRoads survey book by selecting the File > New > Survey Data command. 

4. Enter a name, such as L1234_CAiCESurveyData, and then click Apply.  

Import the WAS file into the survey book: 

5. Select the File > Import > Survey Data command. 

NOTE:  the Linear Units setting defaults to US Feet. 

6. Using the WSDOT InRoads resources, the default Files of Type will be *.WAS.  

7. Browse to the *.WAS file created earlier and then click Import. 

8. Click Close. 

Check for non-standard codes: 

9. Select the Survey > Fieldbook Data command. 

10. Browse through the list of survey points and look for red codes, and note these codes for support 
purposes.  

11. Change those codes that were missed during the CAiCE review to standard codes.  

12. Create a surface by selecting the File > New > Surface command. 

Load the survey data into a surface by selecting the Survey > Survey to Surface command, and 
accept the defaults. 

13. Triangulate the surface by selecting the Surface > Triangulate command. 

14. Review surface by selecting the Surface > View Surface > [triangles] [feature] command. 

For questions or comments on this tech note, contact your regional CAE Support Coordinator or the 
WSDOT CAE Help Desk at (360) 709-8013. 
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